Volgistics

Online volunteer management software

Company  Contact us
_ Home What it does Tour Free trial Cost Store FAQ Get help Blog Login _

System requirements

You can use Volgistics from any computer, anywhere, as long as it has an Internet connection and any popular web browser, including Internet Explorer, FireFox, Safari, and Chrome.

Any of these popular web browsers

Microsoft Internet Explorer  

Internet Explorer
Volgistics is optimized for Internet Explorer, including IE9. Internet Explorer comes with Microsoft Windows operating systems. You can freely download Internet Explorer from the Microsoft web site.

Firefox  

Firefox
Firefox is the next generation browser from Mozilla. Volgistics has been tested for use with Firefox version 1 and later. Firefox is a freely available download at the Mozilla web site.

Safari  

Safari
Mac users can use Volgistics with Apple's Safari browser version 1.2 or later. Safari requires Mac OS X, and is freely available from Apple.


Chrome  

Chrome
Users can use Volgistics with Google's Chrome browser version 16.0.912.77 or later. Chrome is freely available from Google.

Adobe Reader

Adobe Reader  

Adobe Reader
In order to view reports you print from Volgistics, you'll need Adobe Reader 6.0 or later. You can freely download Adobe Reader from the Adobe web site by clicking the Get Adobe Reader' link on this page.

Adobe Flash Player

Adobe Reader  

Adobe Flash Player
In order to view Volgistics training videos you'll need Adobe Flash Player. You can freely download Adobe Flash Player from the Adobe web site by clicking the 'Get Adobe Flash Player' link on this page.

Internet connection

You can use Volgistics from computers with any kind of Internet connection, including dial-up connections, wireless connections, and America Online. If you plan to use Volgistics regularly from a particular location (such as your office), a 'broadband' or high-speed connection such as DSL, cable modem, or T1 is recommended for that computer.

Browser settings

Browsers where you'll use Volgistics must permit JavaScript from web pages at www.volgistics.com (more information). Volgistics does not require cookies, and - with the exception of the optional VicTouch module - Volgistics does not use ActiveX controls.

If you plan to use the VicTouch option, read about the VicTouch system requirements.

Quick Links:

Home
Free trial
Cost
Store
Blog
Login
Tour
What it does
FAQ
Get help
Contact us
Company
Security
Reliability
Terms of use
Privacy policy
System requirements
VicNet
VicTouch
Converting data from other programs
Converting from VolunteerWorks
Create a paid account
Volunteer software copyright
     
 
Tell a colleague